Ошибка доступа в профиль персоны: Элемент с тем же ключом уже был добавлен.
Проблема: При открытии профиля сотрудника, профиль не открывается. Появляется окно с ошибкой “Элемент с тем же ключом уже был добавлен“.
Причина:
Эта ошибка означает, что в структурные справочники персоны было добавлено 2 значения.
В одном справочнике может быть указано только одно значение (один код).
Если при автоматическом создании или обновлении профиля персоны по API было передано 2 значения на один справочник, при открытии профиля в интерфейсе будет получена данная ошибка.
Пример:
В договоре есть структурный справочник Табельный номер. В профиле персоны проставляется код в данном справочнике - табельный номер сотрудника.
При загрузке персоны по API (например, при использовании данного метода) дважды был передан справочник с двумя разными значениями 123, 456:
<OrchestratedPersonMetaCode DictionaryName="Табельный номер" CodeName="123" CodeName_EN="123" CodeValue="123">
<OrchestratedPersonMetaCode DictionaryName="Табельный номер" CodeName="456" CodeName_EN="456" CodeValue="456">
Это означает, что в один справочник попытались установить 2 значения, что является ошибкой.
Решение:
В данном случае достаточно повторно загрузить персону тем же методом, но указать только одно корректное значение:
<OrchestratedPersonMetaCode DictionaryName="Табельный номер" CodeName="123" CodeName_EN="123" CodeValue="123">
Так же необходимо поправить данные персоны на стороне инструмента ИЗ которого происходит загрузка данных сотрудников и оставить только корректное значение, чтобы при последующем обновлении данных ошибка не воспроизвелась повторно.
Если у вас возникли сложности с повторной загрузкой персоны, необходимо обратиться в Okdesk для решения проблемы службой поддержки Corteos.